Merge.

Hi all,

I hope that by my silence you don’t think I’ve been idling, on the contrary: it’s been busy for me!  b995 is largely done, but I’m still sorting out tiny bugs here and there.  There are several patches that still need my attention and I apologize for things taking so long.  To be honest, my attention has been pulled in other directions (and happily so!).

What I HAVE been doing is working on b996.  You might say, “Well, James, why would you do that?  I mean, you haven’t even finished b995??  This shit is buggy as hell!….”  and I wouldn’t argue with you.  But, as it turns out, sometimes that’s just the way things happen.  And this time that’s h0w things are happening.  I wanted to take a minute to spell out plans to those of you that had shown an interest in what’s going on.

I knew things would probably change drastically when Live9 came out, and they did.  b995 was a chore for me, and largely it was centered around making things that already worked in Live8 port over to the new version.  However, none of this was optimal, nor did it take advantage of any of the improvements in Live9.

While creating the modifications to the Push script for AumPush, I was forced (and pleased) to come up with a new way of mod-selection.  Those of you that have used the AumPush script will know what I mean out of necessity:  its just the way things work.  And the nice part about it is that it requries no explanation, really….its just the way things work.  You get it.  And I like it.  But using other controllers to do this same sort of trick isn’t as straightforward, as there is no LCD screen on most controllers, and not as many mode buttons.

I’d been eager to port some mod functionality over to the Base control script for a while, and this couple weeks has seen that happen. I wanted to use the same sort of mod selection mechanism as what I’d used on Push, thus dispensing with “modNumbers” and “modSlots” and all that confusing nonsense.  Base is such a simple and yet powerful device, and I wanted to keep it that way without muddling things by adding an extra layer of confusion with mods.  I’d been unable to use my desired approaches in prior versions of Live due to technical reasons, but to my amazement, when I wrote some new code to this end, things worked!  Ableton/Max had changed their codebase ever so slightly in such a way to allow exactly what I was trying to do!  I now had a much simpler connection routine without many of the limitations that I’d encountered on previous versions of the same type of mechanism.

I wanted to write enough  to explain how and why things will be changing for b996, and why b995 is taking so long.  Things will be changing rather drastically in upcoming versions, and here are the most consequential changes:

Monomodular is a device controller.  

If you select a mod device in Live, it will be selected for control by your controller.  That simple.  (The current paradigm of holding down shift to select a modSlot will still exist on the controllers that support it presently, but it will select a mod in a different, name-based manner, similar to how the DeviceSelectorComponent works in my Livid scripts).  Also in  this regard, you’ll begin seeing the introduction of Python based mods that are recalled any time you select certain Live devices.

Unlimited mods.  

There are no longer modSlots or modNumbers.  Mods are just devices now.

Universal mods.  

I’ve wasted a lot of time trying to maintain slightly different versions of the same mods for Monomodular and different Livid controllers.  This is frustrating, as most of this stuff if essentially the same, with minor differences of details that require constant maintenance to multitudes of files every time a small change is made.  In the future, all mods will be universally supported by all controllers for which I’ve written scripts.  More about this in future posts, as I’m still working out the details.

Easier mod editing.  

Did you ever want to open up a mod and mess around with it?  Or create your own?  Things should be much easier in this regard in b996.

That’s all I have for you now.  If you want a sneak preview of how things will be and you happen to have access to a Livid Base, the new mod design is already in place for it.  Otherwise, I’ll begin porting things over as I have time.

 

Happy blinking!

~ by amounra on June 7, 2013.

44 Responses to “Merge.”

  1. thanks again for all this effort!!!
    I have a question regarding the modlink mod with launchpad.
    I would like to approach through it the different colors of the launchpad, i made some m4l patches which are in monome style but have 4 different led outputs xx0, xx1, xx2 and xx3.
    I could change nonome so it shows now off green yellow and red on the launchpad.
    What could i do to have the same effect with the modlink?

    i want it to show xx0 as off, xx1 as green, xx2 as yellow and xx3 as red…

    Thanks

    Robert

    • It would probably be easier to just port the patch over to a mod using the help.maxpat that comes with Monomodular….it shouldn’t be very hard. If you want to send me the patch I can have a look at it, that would probably be easiest?

  2. Great news ! Very happy with aumpush :-)

  3. hey, there’s no accounting for when inspiration strikes… keep on keeping on!

  4. hey amounra

    i am now just converted it to a mod as you said and it works great, there is still some lag, but i guess there is no way around with all those scripts.

    Ill send it to you when it is done and if you want you could ad it to the mods in your releases.

    i have one question, is it possible to ad two blocks in one m4l patch?
    I would like to use the patch on two different slots at the same time…
    just by copy paste the abstraction in the helpfile it doesnt seem to work. you can choose two different slots but the pasted new one desnt seem to receive and send…

    keep on doing your great work!

    Robert

    • Somehow my first reply didn’t post…..

      Glad to hear you got things working and I’d love to see what you came up with! There is some inherent latency involved with using Python as an input source, but I use some tricks in my own patches to minimize the calls made to mod.js and thus speed things up a little bit. I’ll have a look at what you send me to see if anything can be done.

      Unfortunately there isn’t a way to have a single m4l Device work as 2 separate mods. It’s technically necessary for there to only be one mod.js per patch, as Python uses the device instance to keep track of things on its end. You could easily rig something with 2 separate patches though, using send/receive and a dummy patch to communicate to the second mod instance. You probably already figured this out, but if not let me know and I’ll see if I can help!

      a

  5. Hi Amounra,
    I accidentally found out today that i can run the lemurpad script, and the launchmod script, at the same time, without any problems. If i remember correctly, I couldn’t do that in live 8. It’s pretty cool to have a 256 on my ipad, and a 64 on my launchpad, at the same time sharing mods.

    • It should’ve always worked, but it’s good to know that its working for you now, at least. I usually have one instance each of MonOhm, Lemur256, Codec, and AumTroll manipulating the same group of mods.

  6. Hi,
    My max window is printing thousands of messages, while live’s transport is running, causing some things to clog up. Here’s a picture.

    https://www.dropbox.com/s/gmrhf0w4m2n9lv6/pipe%20osc.PNG

  7. Oh, I’m using the aumpad script, and launchmod script on windows 7.

    • Thanks for the heads up, I forgot to turn DEBUG off when I froze the patch. I’ve pushed a new version to GitHub, it should solve the problem!

  8. Hi James, thanks for all this hard work! love monomodular :)

    I just have a question about your new method of mod selection..

    If you select a device for monomodular to focus on, will that focus all other controllers on it?
    At the moment I use monomod and a bcr2000 and i like that i can control 2 different devices at the same time. when i tried doing the same thing, without monomodular but using push on ableton 9, i got really annoyed with the bcr following push and vice versa.
    i think easier mod switching would be nice, but the bluehand/channel following gets pretty annoying when using more than one controller.

    • I’ve definitely considered this. Since each mod is a device, it will be possible to lock the controller to any mod you wish to.

      I’ve recently been using Push a lot, too, and I’m actually irritated by the lack of a “Device Lock” button. I’ll be adding one to AumPush shortly, hopefully this will solve the problem.

  9. Hi amounra !! Im new with launchpad and monomodular. I have a question if you dont mind. Im using live 9, windows 7 64bits and a launchpad i try withb994 installer but doesnt work, so i install manually. My problem is that when i try to assign monomodular and launchmod as controlsurface im dont get any response from launchpad (no lights. Nothing)i make all the the tutorials, try a lot but nothing!!! Can you please help? Im not into programming but im used to scratch my head and have results. Sorry for my english!
    Patricio

  10. problem solved , everything working good !

  11. hello! did not want to bother you, but I have another query.
    is there any place where you can find information on how to connect Modlink to max / msp devices as mlrv and thepartyvan. I’m using Modlink with other devices and it works ok. but I get stuck when I want to run these apps. thank you!

    • hi patricio,
      Just figured I’d jump in here and help out, since I think we both have the same setup, and these are my two favorite monome apps. The serialosc.maxpat connection method is constantly changing on monome.org, which i would imagine makes it very difficult for Max/Msp wizards like amounra to keep up with. The way I get apps that have been updated with the new serialosc.maxpat, to work is to put this version of serialosc ( there’s a link to it at the end of this post) in C:\Program Files\Cycling ’74\Max 6.1\patches. Then when you download an app, delete serialosc.maxpat from the folder you download, and launch the app. So far, this has worked for me every time.

      https://www.dropbox.com/s/cq43v5o1awze6zz/serialosc.maxpat

      • Hehe, I’m glad you answered….I wasn’t sure how to. I need to update modlink to deal with the new serialosc stuff, but as you said, it seems like they keep changing things. I keep waiting for things to stabilize. When I finally get back to b996 and get it finished, I’ll update things…unfortunately other things have been keeping me away from it lately.

  12. thanks for the feedback friends!!! i will try this tonight hope it works! im into hip hop stuff and really want to try this devices. thanks!

  13. amounraaaaaaaaaaa thnxs for the effort!!!!!!!! go on!! go on!!!!

  14. hi amounra, hi james! i try your serialosc file trick but nothing works! as i said before im using modlink with my launchpad and monome serial apps and it works fine with my Lp. im still new on this so probably im missing someting. can you help with this ?
    thanks amounra for your work!!!!

    • What patches, specifically, are you not having luck with? I’ll try downloading and give it a whirl when I have some time…

  15. mlr or the party van or if you can point some live sampler cutter that you already tried.
    thanks amounra!

  16. i download molar and i will try it tonight i think it matchs with my needs. thanks amounra!

  17. hi amounra!! i try molar and it works fine, mi launchpad got button feedback but no lights( using lp directly).
    i try modlink with this, got visual feedback, but no button response.
    your using molar directly or connected to Modlink? sorry if I’m ignorant.
    thanks!!

    • So sorry patricio….I must’ve missed the mail notifying me about this post.

      I’m not sure what’s going on, but drop me an email and we’ll get it straightened out. I’ve used this a lot with modLink in the past, but it’s been a month or so since I messed with it, I’ll have to refresh.

      a

  18. Help…I spend two days trying to make this work…I dont want to give up :(
    Several Issues
    1. I couldn’t get the Blocks to show up in the actual Plugins.
    2. I can get the Launch Pad to light up and recognize Python Script but no midi out or
    sound.
    3. I have no clue the last time I ate real food lol

    Please help I am new to all of this. I am running OSX 10.8.4 on a 32bit Ableton Live 9 and a Novation LaunchPad (1st Gen. w/Automap). Sorry but I tried for days to get this to work. I watched many tutorials and I am finally asking for help. Any information would be greatly appreciated.

    Thank You!
    Mo

    • Dont’ give up!

      1. The aumhaa blocks folder is missing, or not getting recognized by Max.

      2. Hmmm…that’s kinda cryptic. Can you send me your log.txt file?

      3. Eat some food….it will help!

      Super important: what version of Monomodular are you using, and where did you get it?

      a

      • Hi again I apologize for the fact that I am a novice at this.

        1. After reading the troubleshooting instructions I placed the amuhaa blocks in this path Macintosh HD/Applications/Max 6.1/patches

        2. I don’t know where I would get the log.txt file from :( If I had them how do I send it to you?

        3. I am using Monomodular_b995 I downloaded it from GitHub.

        Thank You for your speedy response :)

  19. Hey aumhaa

    first, i’d like to thank you for your work and your availability! it’s the first time i post something on your blog but i’ve visited it frequently lately and it’s very nice to see you’re always reachable and happy to help :)

    I’m using Live 9 osx, i’ve installed b995 and followed all the instruction on youtube.
    I’ve installed liveclipchopper, so i can really check if it’s working as you say before trying anything else, as i’m a newby.

    First, i had to download the latest Live Clip Chopper on monome.org cos the one inside your folder didn’t show the monome/launchpad pads or the autoConfig. Just so you know. Maybe a bug ?

    Then, here are a couple of strange things which are happening:
    I’ve setted up Launchmod & monomodular inside the midi setting preferences.
    Launchpad lights up no problem. Same for the red rectangle inside ableton.
    Then, i pressed the user1/2 buttons. I get the mixer button to light on, but not in a different color (dunno if it’s important).
    And the red rectangle inside of ableton disapear when i’m in monomodular mode too.

    I open Modlink in a midi channel.
    Then i open LiveClipChopper r34 in an audio channel.
    after clicking a couple of times on manual config/autoConfig, i got Modlink to recognize LCC.
    I load a clip on another audio channel.
    I press play, Rows in LCC moves as it is supposed to do.

    But i can’t get the launchpad to react.
    I have the monomodular mode selected, but the clip doesn’t show up on the pad, and when i press pads, nothing happens.
    I don’t know if it has to work like this, but when i press pads, LCC doesn’t show response (inside the app i mean).

    I don’t know what to do.

    also, another details: do i have to turn the automap server on ?

    if you have any idea of what’s going on :)

    and sorry for this looooooooong message
    cheers

    • oh, and another strange thing:
      when I go to monomodular mode for the first time, the mixer button light on, then i press the mixer button again to go back to launchpad mode, but when i go back to monomodular mode again, the user 1 button flashes in red (and 1 or 2 pads at the button light on in red too).
      dunno if it’s important, but i though i’d let you know.

      • Thanks for this….there is a bug in the script that is turning “shiftlock” on when switching back to modMode…I’ll try to get that fixed shortly.

    • Hey Flore,

      Thanks for the kudos, no worries on the long message.

      I haven’t tested the LiveClipChopper on Live9 yet, so I have no idea if it works with the current setup. I don’t have my Launchpad with me at the moment, and I have a gig tonight, but I’ll be around tomorrow and can check things out for you then.

      A few things: the clipLaunch window is SUPPOSED to disappear in Ableton when you enter modMode.

      You might also try MonoLink and see if it works any better, as it’s already built into the script:

      http://www.aumhaa.com/wiki/index.php?title=MonoLinkComponent

      I’ll get back to you asap!

      • Thanks a lot for your answer.
        I’m gonna try modlink.

        speak later then :)

        • I just tried this with OSX 7.5. Although I couldn’t get things working with MonoLink, I didn’t have any trouble getting ModLink to work. Make sure you set modlink’s mode to MonomeSerial.

          If you’re still having trouble, drop me some mail, I’m sure I can get you going. There’s lots of little details to get right in order to get this monome stuff working right.

          a

          • Hey Amounra, i’ve finally found some time to try what you said, and discovered the reason why i could make it work was it was not setted in monomeserial mode!
            now working like a charm with live clip chopper

            let’s try other apps now ehehe
            thx!

  20. any news?

    • Sooooo busy….but yeah, there will be news shortly. I’ve made a couple of new commits to github lately, but nothing groundbreaking; mostly hex bugfixes and some aumboids features, along with steady changes to the AumPush script. I’ll make a new blog post tomorrow to let everyone know whats going on ;)

  21. To the ones with the Modlink problems: Are you all running on Windows or are there Mac Users who can´t get Modlink runnung with response in both Directions. I run on Windows and get visual Fedback on my LP but can´t send any buttonpresses out to the Monome-Apps. I´ve modified Modlink slightly and voila….it works. Could maybe be a problem with the Operating System (i´m just guessing) so that´s why i ask if there are Mac users with the same Problem

Leave a Reply